OpenRoads Designer CONNECT Edition SDK Help

ConsensusItem Class

Definition

Namespace: Bentley.CifNET.SDK Assembly: Bentley.CifNET.SDK.4.0 (in Bentley.CifNET.SDK.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public abstractclass ConsensusItem : IDisposable
Inheritance → ConsensusItem
Implements

Properties

Connection Gets the Connection of this ConsensusItem instance.
DgnECInstance Gets the DgnECInstance of this ConsensusItem instance.
DgnModel Gets the DgnModel of this ConsensusItem instance.
DomainObject Gets the DomainObject of this ConsensusItem instance.

Methods

CreateFromDgnECInstance Creates a managed item from a managed DgnECInstance.
CreateFromDynamicInstanceId Creates a managed item from its Dynamic Instance ID.
CreateFromNative(ConsensusItem*) Creates a managed item from a native one.
CreateFromNative(T)(ConsensusItem*) Creates a managed item of type T from a native one.
Dispose  
GetNative Gets the native item equivalent from this item.

Operators

Equality(ConsensusItem, ConsensusItem) Gets whether 2 instances are the same.
Inequality(ConsensusItem, ConsensusItem) Gets whether 2 instances are not the same.

See Also